SCCM ConfigMgr DP broken distribution caused by corrupt share permissions

Today i encountered a strange issue with a new distribution point in SCCM v1511.

I had prestaged most content to the DP and this worked fine, status messages were getting back to the MP and so the pie chart in DP Configuration Status section of the console was getting greener and greener. Great!

My prestage script finished sometime over the bank holiday weekend, so I took the DP out of prestaged mode and expected to see content flooding to it. But it didn’t. I started getting errors like this in the content status view. (Ignore the site code and DP name, I have redacted them – they were correct and sane!)

30/08/2016 14:48:00 Distributing content Distribution Manager failed to find or create the defined share or folder () on distribution point "["DISPLAY=\\DPNAME.COM\"]MSWNET:["SMS_SITE=XXX"]\\DPNAME.COM\" for distributing package "XXX00174". Possible cause: Windows NT distribution points might not have at least one available NTFS drive. Solution: Verify that there is at least one NTFS drive with enough free disk space to store the package. Then, verify that the distribution point directory exists, has the proper permissions, and is accessible. Retry Interval is 15 minutes, number of retries left is 5. Error XXX00174

So i checked the status messages and found I was getting a status message id 2324 from the problem Distribution Point.

30/08/2016 06:00:00 Failed to create virtual directory Failed to create virtual directory on the defined share or volume on distribution point "["DISPLAY=\\DPNAME.COM\"]MSWNET:["SMS_SITE=XXX"]\\DPNAME.GLOBAL.ARUP.COM\". Possible cause: Distribution Manager requires that IIS base components be installed on the local Configuration Manager Site Server in order to create the virtual directory. Distribution Manager also requires that IIS Web Services be installed on the Distribution Point Server that needs to support Background Intelligent Transfer Service (BITS). Solution: Verify that IIS base components are installed on the local Configuration Manager Site Server, and IIS Web Services are installed on the Distribution Point Server. Error

I didnt think there would be an issue with the BITS feature, because I had used the Pre-reqs Installer script on this DP – every time I have used it before its been perfect. Besides if the BITS role was missing SCCM would have failed to add the DP role to this server last week. I checked and BITS was still enabled.

The first error was more accurate – “Possible cause: Windows NT distribution points might not have at least one available NTFS drive”. What had happened was that the permissions on the share SMSPKGD$ had become corrupt. However, if i checked the permission they seemed fine. I found a forum post somewhere which suggested just deleting the share and letting SCCM recreate it.

So I stopped the share from Server Manager then rebooted the DP. It took maybe 5 -> 10 minutes for the share to be recreated. But once it was, all distribution issues were resolved!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s